Page 1 of 10 1 2 3 ... LastLast
Results 1 to 20 of 193

  Click here to go to the first staff post in this thread.   Thread: Banner Saga - Bug Report Thread

  1. #1
    Junior Member egil's Avatar
    Join Date
    Jan 2014
    Posts
    1

    really weird graphics bug?

    Hi there! Just got Banner Saga off of Steam and having a good time so far.

    There seems to be a huge graphics bug though. For some reason all the characters show up as white and apart from 3 characters (who for some reason all have bows??) everybody's male. That can't be right. I mean, the Danelaw was alot more diverse than Yorkshire is now. link Also, 3 out of 6 Viking women were buried with weapons, all of them swords.link So everybody being white dudes is clearly a bug, right???

    Does anyone know how to fix this? It's getting really annoying.
    Unto the Anvil, brothers!

  2. #2

    Sound not working at all

    So I loaded up my copy of TBS and was super excited to play!

    ...only to find there was zero audio. My headphones were plugged in - I proceeded to check my speakers, and then all my sound systems. Everything was fine. I could hear sound in every aspect of my computer, even other Steam games.

    Has anyone encountered this?

  3. #3

    Exclamation Tearing

    Right in the main menu, I can see obvious tearing, and there seems to not only be no v-sync option in the settings, but forcing it in my video card's control panel doesn't work.

    Tearing is a total game breaker for me. Is there any workaround for this at the moment?

  4. #4
    Backer netnazgul's Avatar
    Join Date
    May 2012
    Location
    Belarus
    Posts
    513
    Haven't seen any tearing through the game, but it's there when viewing credits. Apparently there is no v-sync currently
    If you don't know where to put it - put it in the pillage

    Steelhammer Tribune issues collected here
    Some of my Factions games can be observed here
    Also possible streaming at http://www.twitch.tv/netnazgul

  5. #5
    Skald Aleonymous's Avatar
    Join Date
    Mar 2013
    Location
    Greece
    Posts
    2,192
    Strange. Have your resolved that? Have you ever played Factions? Did the sound work fine there? I would attempt to update the Adobe Flash player first...
    Together we stand, divided we fall.

  6. #6
    Skald Aleonymous's Avatar
    Join Date
    Mar 2013
    Location
    Greece
    Posts
    2,192
    No tearing in the game itself for me either. It works fine.

    But, in the main-screen/menu and credits, the scrolling-down of the text is a little "choppy"... I mean it's there alright, but it hurts my eyes trying to focus on little details.
    Together we stand, divided we fall.

  7. #7
    Senior Member Rensei's Avatar
    Join Date
    Mar 2013
    Location
    Wrocław
    Posts
    237

    Unhappy Banner Saga - Bug Report Thread

    With people slowly reporting their various problems, I figured we could use one main topic so the guys have easier way to check what's up.
    Mine are below - those are by no means serious ones, just thought Stoic will want to patch stuff at some point (after they're done celebrating a successful launch).

    - Iver's description after his "transformation" reads {ENTITY:iver_desc}
    - Nid is a monster. I promoted her right after she joined and she got something like 10 points (12 exactly - she gets 10 bonus points). She is now level 2 with only two points missing to be completely maxed.
    - Game crashes after a longer session, just like Factions did.
    Last edited by Rensei; 01-15-2014 at 02:38 PM.

  8. #8
    Backer Slimsy Platypus's Avatar
    Join Date
    Nov 2012
    Location
    Northeast US
    Posts
    461
    I experienced a bug where the game left windowed mode, froze on the loading screen, and minimized to a smaller screen size. In both cases I was exiting a battle

  9. #9
    Backer RoBear's Avatar
    Join Date
    Apr 2012
    Location
    MASShole
    Posts
    21
    I found a minor spelling mistake in Chapter 2. During a conversation with Tryggvi after leaving Stogr and passing the godstone. I asked for more of his particular brand of advice and he said something about never trusting people; something about staring you in the eye through a helmet and lying. There was "your" istead of "you."

  10. #10
    "Spoiler" you have been warned. While I was trying to destroy the bridge, anytime a varl got to choose who to attack (was standing next to 2/more people) he would not finish his turn. at that point I cannot take any actions besides opening the menu and either closing or reloading the game. next time I try im going to just have to hope to set it up with them all stuck with only one option to attack, but that hasnt been fruitful so far.

  11. #11
    Skald Aleonymous's Avatar
    Join Date
    Mar 2013
    Location
    Greece
    Posts
    2,192
    Here's some from me:

    • Sigbjorn's description (when in PGs/Heroes screen) is the generic WH from Factions, not personalized.
    • Typo -- Right after/before meeting Sig, there's a typo saying something like "...they caravan..." (the "y" shouldn't be there).
    • Buff/Debuff icon flashing on all character portraits (check pic below)
    • I think I had an issue with the Silver Arrow vs. Bellower, but didn't grab a snapshot. So, his ARM was at 10 and so was Rook's STR. Rook was in-range and the UI lighted up the purple tiles for the Silver Arrow attack. However, even though Bellower was in-range (one of his 2x2 tiles was), I couldn't select him as a target!


    Together we stand, divided we fall.

  12. #12
    Backer RoBear's Avatar
    Join Date
    Apr 2012
    Location
    MASShole
    Posts
    21
    Spelling mistake first time talking to Yrsa; "She watches you approach with her held tilted back, and points a thumb toward Ludin's tent." Direct quote.

  13. #13
    Backer gotthammer's Avatar
    Join Date
    Apr 2012
    Location
    lost in the Uncharted Territories
    Posts
    19
    Just two bugs:
    - stopped responding after a few hours. Only happened once, and I was alt+tab'ing a lot.

    - when I used Rook's "Mark Prey" ability on a dredge ranged unit (slinger?): the ability triggered, multiple units attacked the dredge (including ranged attack from 2 of my archers) slinger moved (was moving while taking damage, if I remember the animation sequence correctly). After moving and damage had been dealt (it survived), the combat turn didn't progress/move to the next turn.
    Everything else in the UI seemed fine, but I couldn't do anything to continue the fight. I loaded a game and went through the fight again w/ no problem, and I've never encountered that or a similar bug again.

    I think I also saw some typos and maybe a grammatical error or two, but I didn't take note. Sorry.
    "Thou shalt not make a machine in the likeness of a human mind."

  14. #14
    When I boot up the game and it enters the title screen I see no menu and no matter what button I press or wherever I move the mouse and click I cannot go any further.

    I somehow managed to make the menu appear once and got into the game. I was able to load the game and everything worked just fine.

    But now when I could play the game again, I press escape on the title screen and try to resume or to load a game it doesn’t work. There is seemingly no games to load when I click resume it goes back to the title screen.
    Here are some pictures to show you what is happening.



  15. #15
    Backer angelcatano's Avatar
    Join Date
    Oct 2012
    Location
    Europe
    Posts
    27
    Can corroborate this, but mine happened in another transition, think from a conversation into a city view
    - Iver's description after his "transformation" reads {ENTITY:iver_desc} as well
    Sigbjorn's description (when in PGs/Heroes screen) is the generic WH from Factions, not personalized.

    and a new one:

    several typeos:
    Iver carrying (SPOILER) Allette with his Arms
    The description of the Ventur Sea, last sentence seems to be wrong, It says: "...and no ports of note alone the east coast..." , feels like alone should be along

  16. #16
    Skald Aleonymous's Avatar
    Join Date
    Mar 2013
    Location
    Greece
    Posts
    2,192
    Quote Originally Posted by gotthammer View Post
    when I used Rook's "Mark Prey" ability on a dredge ranged unit (slinger?): the ability triggered, multiple units attacked the dredge (including ranged attack from 2 of my archers) slinger moved (was moving while taking damage, if I remember the animation sequence correctly). After moving and damage had been dealt (it survived), the combat turn didn't progress/move to the next turn.
    Everything else in the UI seemed fine, but I couldn't do anything to continue the fight. I loaded a game and went through the fight again w/ no problem, and I've never encountered that or a similar bug again.
    I think this is the infamous game-stopping bug that they've been hunting for a long time! Where there any burning coals around? I would suggest that you find & backup the game logs, where this bug happened, and email them to Stoic.
    Together we stand, divided we fall.

  17. #17
    Backer LoliSauce's Avatar
    Join Date
    May 2012
    Location
    Las Vegas
    Posts
    166
    Okay, so I caught a bug on video. It's also relating to the slingers, but it didn't hang the entire match. In the fight, I had used Tempest on two adjacent dredge, the grunt died from the attack but the slinger was brought to 1 STR, which he then took the shockwave's splash damage, killing him as he started his move animation away. As you can see in the video, he got stuck looping the move animation (complete with repeating footstep sounds and everything) though he was dead.

    http://www.twitch.tv/lolisauce/b/495595333 (skip forward to 1:50:45)


    Sounds like these slingers have been causing some issues, eh?

  18. #18
    Member Leartes's Avatar
    Join Date
    Feb 2013
    Location
    Aachen - Germany
    Posts
    92
    Transition from chapter 4 to 5, I started the dialog at the end of chapter 4 and when it should jump to the scene with Juno it went from fullscreen to windowed and the screen stayed black with the 'loading' text in the bottom right corner.

  19. #19
    I chose Rook to carry the arrow, but it's not showing up in his action selection, so I can't tag Bellower with it and proceed.

  20. #20
    Quote Originally Posted by gotthammer View Post

    - when I used Rook's "Mark Prey" ability on a dredge ranged unit (slinger?): the ability triggered, multiple units attacked the dredge (including ranged attack from 2 of my archers) slinger moved (was moving while taking damage, if I remember the animation sequence correctly). After moving and damage had been dealt (it survived), the combat turn didn't progress/move to the next turn.
    Everything else in the UI seemed fine, but I couldn't do anything to continue the fight. I loaded a game and went through the fight again w/ no problem, and I've never encountered that or a similar bug again.
    I just had exactly the same issue, using the same ability. I have the log if needed, but can't seem to attach it here.
    Crest by StandSure, many thanks!

Page 1 of 10 1 2 3 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO