View Full Version : Unit overlay UI animation is very slow (and frustrating)

02-24-2013, 04:59 PM
I just want to say, I love the game; it's filling the turn-based strategy itch I've had for a long time. However, there a few really frustrating interface issues that have lead to a number of losses. I'll see if I can explain the thread title.

When you click on one of your units, the overlay that pops up with unit options animates in. This seems to need to be fully animated before it becomes clickable, and often slows down considerably which has lead to a number of losses because I can't click the interaction in time.

If I could make a suggestion, it would be to remove the animation on this overlay and have it just pop instantly. I don't know if that would solve the issue here, but it seems like even with 5 seconds left on the timer the animations and such cut that down to like 1 or 2s of time with which to act.

Thanks for the game Stoic! :)

02-24-2013, 06:35 PM
I agree, they need to cut the animation out.

02-24-2013, 06:43 PM
Yeah, it makes the timer a false indicator of the time you have left, and punishes slow computers more, so I agree!

02-24-2013, 07:29 PM
There are some performance-updates coming, but I agree to the problem. For renown-issues, I usually play with the 30 s timer and this issue makes it harder than it should be.

But I'm confident, this is one of the next things that will be fixed.

02-24-2013, 08:30 PM
I agree, they need to cut the animation out.

+1. Later they can add an option for the user to put them back in, once there are some UI options...

02-25-2013, 06:43 AM
I've missed turns due to this issue. It also doesn't help that it sometimes takes you 2 clicks to register an action.

02-25-2013, 10:08 AM
Confirming that one - it was hell of a pain in early betas (with vector graphics), but is still an issue now, especially when trying to frantically click on that one last button during last two seconds of your turn.

02-27-2013, 08:10 PM
I think this is an excellent idea, we will look into adding this into the options to remove animation. I would also check to see if you have hardware acceleration turned on if you are a windows machine.

Steps below: