View Full Version : Game crashes every first start

02-27-2013, 12:59 PM
Since a steam update some days ago the game sadly crashes ever first start after displaying me my daily login streak. This is the error in the event log:

Log Name: Application
Source: Application Error
Date: 26.02.2013 19:45:56
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: private
Faulting application name: The Banner Saga Factions.exe, version:, time stamp: 0x508e0455
Faulting module name: Adobe AIR.dll, version:, time stamp: 0x508e04d9
Exception code: 0xc0000005
Fault offset: 0x0054afe7
Faulting process id: 0x6f8
Faulting application start time: 0x01ce14517cf3d936
Faulting application path: d:\games\Valve\Steam\steamapps\common\the banner saga factions\win32\The Banner Saga Factions.exe
Faulting module path: d:\games\Valve\Steam\steamapps\common\the banner saga factions\win32\Adobe AIR\Versions\1.0\Adobe AIR.dll
Report Id: c0ea0a90-8044-11e2-b902-20cf307edd7a
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<TimeCreated SystemTime="2013-02-26T18:45:56.000000000Z" />
<Security />
<Data>The Banner Saga Factions.exe</Data>
<Data>Adobe AIR.dll</Data>
<Data>d:\games\Valve\Steam\steamapps\common\the banner saga factions\win32\The Banner Saga Factions.exe</Data>
<Data>d:\games\Valve\Steam\steamapps\common\the banner saga factions\win32\Adobe AIR\Versions\1.0\Adobe AIR.dll</Data>

02-27-2013, 01:00 PM
Every start afterwards it is running fine.

02-27-2013, 02:42 PM
[INFO] (TBS-0) 0 579 Build:
[INFO] (TBS-0) 0 580 Version: 1.5.97
[INFO] (TBS-0) 0 580 Id: 2013-02-26_16-55-56
[INFO] (TBS-0) 0 580 Capabilities:
[INFO] (TBS-0) 0 580 isDebugger: false
[INFO] (TBS-0) 0 580 language: en
[INFO] (TBS-0) 0 580 manufacturer: Adobe Windows
[INFO] (TBS-0) 0 580 os: Windows 7
[INFO] (TBS-0) 0 580 pixelAspectRatio: 1, dpi: 72
[INFO] (TBS-0) 0 580 playerType: Desktop
[INFO] (TBS-0) 0 580 resolution: 1280 x 1024
[INFO] (TBS-0) 0 580 touchscreenType: stylus
[INFO] (TBS-0) 0 580 version: WIN 11,5,502,110
[INFO] (TBS-0) 0 588 CONFIG HOSTS buildRelease=dev
[INFO] (TBS-0) 0 640 AirAppInfo.loadIni checking for iniFile: file:///C:/Users/admin/tbs_config.ini
[INFO] (TBS-0) 0 674 SteamworksAne loaded
[INFO] (TBS-0) 0 675 SteamAPI_RestartAppIfNecessary RESULT 219340 false
[INFO] (TBS-0) 0 805 SteamAPI_Init RESULT true
[INFO] (TBS-0) 0 805 STEAM Init OK attempt 0
[INFO] (TBS-0) 0 881 invokeHandler reason=standard arguments=
[INFO] (TBS-0) 0 881 invokeHandler appInfo.nativeAppUrlRoot=file://d:/games/Valve/Steam/steamapps/common/the banner saga factions/win32/
[INFO] (TBS-0) 0 881 cwd=file:///d:/games/Valve/Steam/steamapps/common/the%20banner%20saga%20factions
[INFO] (TBS-0) 0 882 arguments length=0, value=
[INFO] (TBS-0) 0 882 renderMode=direct
[INFO] (TBS-0) 0 882 No command line arguments, using AppInfo args=[null]
[INFO] (TBS-0) 0 884 parseArguments
[INFO] (TBS-0) 0 886 spritesheet=true
[INFO] (TBS-0) 0 890 CONFIG runMode=BETA
[INFO] (TBS-0) 0 890 CONFIG assets=file://d:/games/Valve/Steam/steamapps/common/the banner saga factions/assets
[INFO] (TBS-0) 0 890 CONFIG gui=file://d:/games/Valve/Steam/steamapps/common/the banner saga factions/gui/
[INFO] (TBS-0) 0 890 CONFIG server=http://tbs-dev-live.stoicstudio.com/
[INFO] (TBS-0) 0 1778 FmodSoundDriver loaded
[INFO] (TBS-0) 0 1800 FmodSoundDriver initialized
[INFO] (TBS-0) 0 1802 FmodSoundDriver.onStatusEvent info: initFMOD
[INFO] (TBS-0) 0 1802 FmodSoundDriver.onStatusEvent info: FmodAne::System_GetVersion: 0x00044402
[INFO] (TBS-0) 0 3077 HttpCommunicator hostUrl=http://tbs-dev-live.stoicstudio.com/
[INFO] (TBS-0) 0 3163 SteamUser_GetSteamID RESULT xxx
[INFO] (TBS-0) 0 3163 SteamID_GetAccountId RESULT xxx
[INFO] (TBS-0) 0 3163 StartState.handleEnteredState $$ STEAM ID=xxx, account xxx
[INFO] (TBS-0) 0 3163 StartState.handleEnteredState $$ showing login screen and completing
[INFO] (TBS-0) 0 3167 PreAuthState.handleEnteredState STEAM TICKET=2/xxxx
[INFO] (TBS-0) 0 3170 AuthState AUTHENTICATING http://tbs-dev-live.stoicstudio.com/, xxxx: 0 steam=xxxx
[INFO] (TBS-0) 43 4971 Credentials.sessionKey xxx null xxxx xxxx
[INFO] (TBS-0) 43 4971 Assigned SessionKey xxxx
[INFO] (TBS-0) 64 7113 Saving Prefs
[INFO] (TBS-0) 92 9512 AnimClipDef.cacheFrames AnimClipDef{_id:"vfx_soldiers_wall", _url:"town/strand/vfx.strand.swf/vfx_soldiers_wall", _numFrames:982} is too large, giving up at frame 191/982 after MB=50

02-27-2013, 04:11 PM
Try reinstalling the game - it fixed this same issue for me.

02-27-2013, 07:27 PM
You're getting the same error as I am. http://stoicstudio.com/forum/showthread.php?1048-Game-crashes-on-startup my game crashes every time but the first after installing though. Reinstalling doesn't fix the issue.

A lot of people are getting this problem. It really needs to be addressed.

02-27-2013, 09:06 PM
I had the same problem on my machine a reinstall of the game fixed the issue. If that doesn't work I would check out some of crash notes and fixes found here http://stoicstudio.com/forum/showthread.php?1067-Build-1-5-106

03-04-2013, 07:19 AM
Same error here. A reinstall fixes the error, but only for several executions. Is there a local cache perhaps that runs into a maximum size? Are you rebuilding the swf every time? Regardless, this is an issue still standing. Obviously, this being a beta, if you can recommend a workaround, we could use it -- the game is awesome, but not enough to reinstall every time I want to play it :D

03-05-2013, 08:45 PM
Keeps crashing, was running fine before, exited, and now keeps crashing.

Running Win8 64bit with latest java (32 and 64bit), using AMD A8 with integrated vid. Will reinstall.

03-08-2013, 05:45 AM
The error is still present. I tried reinstall / reintstall in a different location and every time the game crashes. Please make a patch and fix it or tell me how to bypass the error. Thank in advance.