View Full Version : Still crashing every 2nd launch after every re-install on Steam version

03-01-2013, 03:19 AM
I use Windows XP Service Pack 3. Game still crashes when I try to launch it for the second time. First time launches very smooth and I have had no problems playing matches. But the second time I try to launch the game it always crashes. I have checked the forums and have checked that I have the Hardware Acceleration active (this is a fix for a performance issue but I tried it anyway). They say there is a new build that is addressing this problem but maybe the build is not out yet or is not the one downloading from Steam. The only other solution I saw was to download the game to a different folder. I am not sure that is an option for Steam, It is my understanding that the game needs to be in the correct directory to authenticate through Steam.
Right now I have to reinstall the game every time I want to play. It's getting bothersome and I hope they will fix this soon.

This is a copy of my post on the Steam community hub. I will e-mail the logs to community@stoicstudio.com.

03-01-2013, 03:55 AM
Thanks for posting. We'll get back to you.

03-01-2013, 05:07 AM
HI guys,

Have same problem, on same platform XP SP3, re-instaling doesnt help.

03-02-2013, 02:03 AM
Once again... yup. Appears to be a very common problem. I discovered you can actually run this game by just dropping it into another folder, and that occasionally circumvents this bug every once in a while. Not a fix, but it might get you another play out of the game before you have to reinstall.

For reference:

Threads here (http://stoicstudio.com/forum/showthread.php?1062-Game-crashes-every-first-start) and here. (http://stoicstudio.com/forum/showthread.php?1048-Game-crashes-on-startup)

03-02-2013, 12:26 PM
Same here. Kind of annoying...

03-02-2013, 08:13 PM
I just had one of these too, but simply relaunching the game via Steam allowed me to get back in. Posting logs of it just in case.

Event viewer log: http://krd.clansfx.co.uk/dump/d8abebb801d4bf8d91b617370c111a40/0000003B.txt

Game log: http://krd.clansfx.co.uk/dump/bb194ca2be10b44d98fbfb966512c711/com.stoicstudio.TheBannerSagaFactions_A-1.log.txt

Dr. Cheesesteak
03-02-2013, 08:30 PM
I have a crash on startup problem, but it's a bit different. Whenever I start the game via my desktop shortcut or the steam icon at the taskbar, it crashes a few seconds after starting. If i start the game via my library on the actual steam program, it's fine.

03-02-2013, 09:17 PM
Welp, that's odd. I only ever launch Factions via clicking the Steam tray icon and I got that crash the once too, but not since. :confused:

Dr. Cheesesteak
03-03-2013, 01:15 AM
Welp, that's odd. I only ever launch Factions via clicking the Steam tray icon and I got that crash the once too, but not since. :confused:
well, of course now i just had my first crash-on-startup from Steam Library. So I guess it's just a crash that can happen at any time during any kind of startup...

03-06-2013, 01:45 PM
Interesting info, we will be inserting some diagnostics in the next build to see if we can resolve the crash

03-07-2013, 05:45 PM
Good to hear - I'm also having this issue, and with as much as I love the game, it's soul-crushing.

03-07-2013, 06:52 PM
On my computer, the game crashes, like, 11/12 times when I try to start it up. Except it's not just a mysterious crash, it's "Data Execution Prevention" closing it for some reason. I'm on Vista.

So I end up just relaunching the game over and over until it decides to not get murdered by DEP.

03-07-2013, 10:03 PM
Not working for me too. Gotta reinstall everytime. Fairly fast, but still

03-07-2013, 11:37 PM
Is there a way to reinstall in Steam without having to re-download?

03-07-2013, 11:44 PM
Seems like the issue is related to Steam Community. Found this on the Steam forums:

I got it to work by disabling Steam Community. Right-click the game in your Library, Properties. On the General tab, uncheck "Enable Steam Community In-Game". Click Close. I've launched the game successfully about 5 times since. Hope it helps.

03-08-2013, 03:44 AM
I disabled Steam community just for the game, no luck. Then disabled it for my entire account, no luck. Disabled Cloud Sync for my account, no luck. I restarted steam after every change, but I did not re-install the game before trying the above.

EDIT: Re-installed the game and repeated the experiment. No change, getting the same crash as the one in my original post on this thread (works the first time after re-install, but crashes on load screen on any launch after).

03-08-2013, 09:10 AM
hey. I have the same issue, BUT after the update i have reinstalled 4 timesand still cant launch the game. community thing didnt help either.

03-08-2013, 11:37 AM
If you mailed stoic, then they will get back to you soon. Hang tight, it's just a bit busy. to be sure, mail again ;)

03-08-2013, 05:23 PM
Disabling Steam Community worked the first time I tried it, but it's remained off and I still get crashes after the first time I launch after a reinstall.

Roidosaurus Pecs
03-08-2013, 05:27 PM
I seem to be having a similiar issue, whenever I launch the game it will crash before it can load up completely, however if I re-install the game it will work the first time I launch it, but once I try to launch it again it will stop working.

03-09-2013, 08:00 AM
just wanted to make sure if I've the same problem as you


03-09-2013, 04:49 PM
Yup that's the one.

03-13-2013, 06:10 PM
this bug is since 3 day after release... for 2 weeks now... anything?

03-15-2013, 11:42 AM
We found one frequent and reproducible crash, and fixed it in this build. I'm not sure if it gets every case, but it was certainly an important one. If you have been suffering from crashes, please try again and let me know if it does or does not help.