View Full Version : Console Error (Red Screen) on Execution

07-11-2018, 11:31 PM

I was hoping to replay The Banner Saga and The Banner Saga 2 in preparation for the final game, but I get this red screen with the words 'Console Error' on both games.

Details that might help:
I first installed both games through the GOG Galaxy client. I also added YaK's mods to both games. (Red screen/Console Error on both games.)

I then uninstalled and reinstalled both games still through the GOG Galaxy client, but without the mods this time. (Red screen/Console Error on both games.)

I then uninstalled and reinstalled both games without using the client, again trying to add YaK's mods. (Red screen/Console Error on both games.)

I then uninstalled and reinstalled both games without the client and without mods. (Red screen/Console Error on both games.)

The frustrating and confusing part is that I've played both of these games on this computer before, the only change I've made to my hardware is adding a graphics card. (Hardware, if that matters: cpu - AMD A8-3850 APU, gpu - Gigabyte GT 730. OS - Windows 10)

Any suggestions would be greatly appreciated.
Thank you.

07-12-2018, 08:42 AM
Hmm, can you look inside the gamelogs for details on the Errors? Your system looks fine.

Gamelogs should be inside your "data" folder. But, I don't know where that can be found for GOG, most likely somewhere in your user-documents (for Steam it's: %HOMEPATH%\AppData\Roaming\TheBannerSaga2\Local Store\gamelog\).

07-12-2018, 09:59 AM
Thanks for the help.

Steps taken:
Reinstalled The Banner Saga without the GOG client. Ran it once. Found a gamelog file in the folder you mentioned.

Two 'ERROR' messages are present. One is for presumably for failing to load nonexistent save files, and one that is harder to understand.

I keep trying to post the contents of the log file here, but I get redirected to a 'Forbidden' notice generated by Wordfence. How should I post the log file?

403 Forbidden

A potentially unsafe operation has been detected in your request to this site.

Generated by Wordfence at Thu, 12 Jul 2018 14:53:57 GMT.
Your computer's time: Thu, 12 Jul 2018 14:53:55 GMT.

07-12-2018, 04:05 PM
Can't you just copy-paste the contents of the log-file (as text) here? Else, put the logfile in some external cloud (dropbox, google-drive etc) and generate and paste a link to that here.

07-12-2018, 07:18 PM
Link to log file on Google Drive:

(Sorry if I didn't communicate effectively. I did try to Copy-Paste the log file contents, but when I clicked the Post button, I was redirected to a different 'Forbidden' webpage that I quoted in my last post.

I tried pasting the text several times. First, directly copy-pasted from the log file. Second, surrounding it with the 'quote' tags. Third, surrounding it with 'code' tags. Fourth, only pasting the Error lines of the file.

I have no idea what I was doing wrong.)

07-13-2018, 09:51 AM
OK, so what configuration does this Saga1 log refer to -- Is it without Galaxy and without mods? It's the last log generated (the one with the latest "modified" timestamp) in the folder, after a failed launch (getting ConsoleError flashing etc)?

07-13-2018, 04:49 PM
This was the last configuration: Installed WITHOUT the GOG Galaxy client. It was the first log file generated.

I have since tried to open the game twice, generating two more log files. The newest log file is always named A-0. The only difference I see between the first log file and the newer ones is the absence of the Save error (probably because they automatically generated save preferences during the first run attempt).

Also, even though I installed the game without the client, the client still recognizes the install (probably because the install is located in the GOG folder created by the installer program) and I can still launch the game from the client (though the result is the same Red Screen/Console Error).

07-14-2018, 11:12 AM
OK, thanks. I can't understand what goes wrong, but the ERROR appears when GOG elements are being loaded, so I guess it must be related to that. I don't have the game on GOG, but here's how a "healthy" log from Steam looks like:

[INFO] 0 1475 (INIT) build_platform=[steam]
[INFO] 0 1887 ( ) INVOKE reason=[standard] arguments=[debug]
[INFO] 0 1887 ( ) INVOKE approot=[file:///E:/Games/Steam/steamapps/common/tbs/win32]
[INFO] 0 1887 ( ) INVOKE CWD=[E:\Games\Steam\steamapps\common\tbs]
[INFO] 0 1888 ( ) doSetup with assetsUrl=[null] nativeRoot=[file:///E:/Games/Steam/steamapps/common/tbs/win32]
[INFO] 0 1888 ( ) SaveManager.MigrateSavesToProfile saga1
[INFO] 0 2012 ( ) ARGS (1) [debug]
[INFO] 0 2012 ( ) parseArguments debug
[INFO] 0 2015 ( ) parsing arg debug
[INFO] 0 2015 ( ) PlatformStarling STARLING INIT
[INFO] 0 2026 ( ) PlatformStarling resize viewport to 1024x768
[INFO] 0 2027 ( ) SteamEntryHelper.setup
[DEBUG] 0 2028 ( ) SteamworksAne.create creating extension context air.steamworks.ane.SteamworksAneContext
[DEBUG] 0 2028 ( ) SteamworksAne extension dir file:///E:/Games/Steam/steamapps/common/tbs/win32/META-INF/AIR/extensions/air.steamworks.ane.SteamworksAneContext
[DEBUG] 0 2137 ( ) SteamworksAne.create created extension context [object ExtensionContext]
[DEBUG] 0 2137 ( ) SteamworksAne loaded
[DEBUG] 0 2138 ( ) SteamAPI_Init
[INFO] 0 2369 ( ) SteamAPI_Init RESULT true
[DEBUG] 0 2369 ( ) getVersion
[DEBUG] 0 2369 ( ) getVersion RESULT 3

The part marked in green is approximately the same as in your log file, right before the error pops up. So, since re-installing etc doesn't seem to help, I recommend contacting support[at]stoicstudio[dot]com directly, attaching this file.

07-14-2018, 03:40 PM
Thanks for all your help. I'll send them an email now.

07-16-2018, 08:34 AM
Hi @ConsoleError we're sorry to hear you've had this issue with the game. I've received your email and will review with our QA Lead. I'll let you know in a response to that email if we have any further questions. Thank you!