View Full Version : Saga Banner Faction crashes

02-21-2013, 03:30 PM
Yesterday I played nicely. Today there was a steam update and the program crashed. Anyone else experiencing this?

02-21-2013, 03:33 PM
Yeah just tried to start it a few times after it updated, crashes every time on the loading screen...

edit: Seems it fixed itself now.

The New Romance
02-21-2013, 05:05 PM
Sometimes the game crashes for no apparent reason during startup. Seems to have great self-healing techniques, though ;)

02-21-2013, 11:17 PM
I have also had the game crash a couple times on startup for me today. Always worked when I tried again though. Is there a log file or something we could attach to help troubleshoot the issue?

02-21-2013, 11:29 PM
Yes there's a log file:

The game always writes log files into $HOME/tbs_logs/. You can access this or email it to us for bug reporting

C > Users > Username >tbs_logs

Email to community@stoicstudio.com :)

02-24-2013, 02:54 AM
The update on 22nd broke it for me too, hasn't recovered yet. We are not alone in this :) Apparently, some animation's too large now, if the logs are to be trusted

02-25-2013, 04:32 PM
There might be a memory leak, or assets are not being unloaded properly. In addition to the error message in the log (below), Task Manager shows the memory increase a lot when you enter a match, then decrease only slightly when you leave. The game launched using about 350MB (in town screen), after one game it was 700mb (in town screen) and after two was at 900mb (in town screen). I looked one time after it crashed, with not responding, and it was at 1.3GB.

(FROM ERROR LOG, Have seen it numerous times)
[INFO] (TBS-0) 37 2671 AnimClipDef.cacheFrames AnimClipDef{_id:"vfx_soldiers_wall", _url:"town/strand/vfx.strand.swf/vfx_soldiers_wall", _numFrames:982} is too large, giving up at frame 191/982 after MB=50

02-25-2013, 04:36 PM
And to clarify, the memory issue is not on my end, the system I use has 16GB Ram.

02-27-2013, 08:14 PM
I have had issues with this on my machine and deleting the local content on steam and repatching fixed the problem. If that doesn't work let me know sounds like the same problem.

Here is more notes about crashes and fixes for them: http://stoicstudio.com/forum/showthread.php?1067-Build-1-5-106

02-28-2013, 03:10 AM
Today's update didn't fix the issue, and re-installing doesn't help either. :( E-mailed the log to community@ already :(

The sad thing is that it worked at launch before the update came out on 22nd, I think

02-28-2013, 01:18 PM
bleys try saving the game on a different folder path.

03-01-2013, 03:16 AM
Just how many times trying to save to the different path is enough? It's the first thing I've done on John's advice. Retried right now to make sure nothing's changed.

03-01-2013, 04:57 AM
Indeed, the bug still lives. Yesterday I thought it worked after exiting the game and I assumed the problem was fixed, but maybe it was a fluke. It hasn't worked since and in its current state the game in unplayable.

I keep telling myself that I should try it next week or the week after again, but I like it so much I keep coming back, trying to connent, only to be disappointed again. Hopefully, they will work this out soon, because the issues seem to pile up instead of reduced.

Oh, and saving to a different folder doesn't help; I tried it with 3 different ones but I always get the same result.

03-06-2013, 01:22 PM
We will be inserting some diagnostics in the next build to see if we can resolve the crash.

03-09-2013, 11:50 AM
Not sure about the diagnostics, but the crash was indeed miraculously cured with the new update.

Alas, no more first-week perks anymore :(

03-09-2013, 05:15 PM
Spoke too soon. The crash was back on the second launch. Sending fresh logs

Dr. Cheesesteak
03-09-2013, 05:44 PM
count me as a crasher on startup, too!

01-22-2014, 05:04 AM
Found the fix for the crashes! Check this guide How to Fix The Banner Saga Crashes, Stuttering Cutscenes, and Black Screen Issues (http://www.crashwiki.com/how-to-fix-the-banner-saga-crashes-stuttering-cutscenes-and-black-screen-issues/)

02-12-2014, 05:00 PM
I was also getting The Banner Saga: Factions crashing on startup, but only when launched through Steam. If I go to the install folder and manually run "The Banner Saga Factions.exe" then it works fine.

I the noticed that if I go into the game properties within Steam and untick "Enable Steam Community In-Game" then it no longer crashes, so it's something to do with the Steam overlay I guess.

Sadly the log file location mentioned above doesn't appear to exist on my box.



02-12-2014, 06:02 PM
Sadly the log file location mentioned above doesn't appear to exist on my box.

Hey there. Log file locations are:
Mac OS X: ~/Library/Application Support/TheBannerSaga/Local Store/logs/
Windows: %HOMEPATH%\AppData\Roaming\TheBannerSaga\Local Store\logs\

This crash persists; I get it too, 50% of the time :( Some have fixed it by disabling the steam overlay, others by disabling the sound of the game.