Page 1 of 2 1 2 LastLast
Results 1 to 20 of 24

Thread: Banner Saga doesn't start

  1. #1

    Banner Saga doesn't start

    Hello stoic and fellow vikings

    Since two days, the Banner Saga doesn't work for reasons unknown. Steam is updated but the game gets stuck at the initial loading screen, so I cannot enter Strand.

    Does anyone know what the issue might be?

    Thanks for your help.


    - Argail

  2. #2
    Skald Aleonymous's Avatar
    Join Date
    Mar 2013
    Location
    Greece
    Posts
    2,444
    Hello Argail.

    I've had a similar issue a couple of times, but it was some temporary server problem, typically resolved in 1-2 hrs. This happens everytime?

    What's your TBSF client build? Current is 1.8.95. Perhaps you gotta force an update?

    Perhaps some Firewall/Antivirus issue?

  3. #3
    Hello Aleonymous

    Hm, I am not quite sure on where to see my current build. Usually, the game updates automatically which corresponds to my steam settings. Yes, it happens every time, since about two days. There was a general steam update inbetween but it didn't change much.

    Firewall/ Antivirus never was a problem, why should it be now?

    - Argail

  4. #4
    Skald Aleonymous's Avatar
    Join Date
    Mar 2013
    Location
    Greece
    Posts
    2,444
    The current build version, you can briefly see it when the game launched (when in Full-screen), or on the window's title-bar (when in Windowed-mode).

    Yup, I've seen the Steam updates a few days ago. Actually, it was quite some of them, but they didn't harm my game.

    OK, since nothing has changed with your FW/AV, then its probably something else. You don't get some sort of that "blue screen" before the game-launch screen, do you? If it happens, just close it/leave; you might break your game if you enter in some "offline/debug" mode.

    Meanwhile, I'd suggest your email the support directly and also post your issue at the chat. Sometimes the devs show up there, and the mods/admins drop by now-n-then and might have some more troubleshooting ideas.
    Last edited by Aleonymous; 06-09-2013 at 06:33 AM.

  5. #5
    Factions veteran stoicmom's Avatar
    Join Date
    May 2012
    Location
    Oak Ridge, TN
    Posts
    290
    i reported the problems mentioned above and got a response. "the server is set up to recover from problems after about 15 minutes" yes, lots of problems for me and others since steam had multiple updates in one day. i encourage you to report them immediately to the devs (i email them all) john@stoicstudio.com, arnie@stoicstudio.com, and alex@stoicstudio.com so they get feedback from more people than me. i'm usually catching comments in global chat about problems or in this chat or threads. better to let them know imho

  6. #6
    Hello guys

    Thanks stoicmom, I contacted stoic about the issue and got a response from John pretty much at an instant. Which in itself is awesome. According to the log files some kind of program stops the game from starting - which makes sense in theory, but practically I haven't installed any new programs since the error appears.

    Also, even with firewalls and security programs off (ms essentials) it doesn't start.

    Any further ideas?

  7. #7
    Member Yth's Avatar
    Join Date
    Mar 2013
    Location
    Vienna, Austria
    Posts
    70
    I'm experiencing the same issue - loading screen with the spinning axes doesn't ever end, so I can't get to the strand/load the game. The last time Factions was able to load was about 24 hours ago, on the 11th.

    The window label says I am running Factions 1.8.95

    Things I have tried:
    -Messing with / turning off firewall
    -Reinstalling TBS:F
    -Virus checks
    -Various steam settings

  8. #8
    Skald Aleonymous's Avatar
    Join Date
    Mar 2013
    Location
    Greece
    Posts
    2,444
    Hello Argail. Some questions/suggestions

    1. This keeps happening every time, i.e. you have never played normally (on that PC)?
    2. Have you actually tried un- & re-installing Steam and TBSF?
    3. Have you tried playing from another user-account (same PC), in safe-mode (windows) or from another PC?
    4. Where are you from, if you don't mind me asking. Some people in Asia have reported similar (but not identical) problems.
    5. Perhaps it's some sort of a conflict with Internet-provider policies. Similar issues might appear on restricted-access networks, e.g. in university or company PCs.
    6. Do you have problems with other online/PvP games on Steam (or in general with online/PvP)?
    Last edited by Aleonymous; 06-12-2013 at 11:44 AM.

  9. #9
    Member Yth's Avatar
    Join Date
    Mar 2013
    Location
    Vienna, Austria
    Posts
    70
    My results to Aleon's query:
    1) Only happening since 24 hours ago
    2) new installation of steam and TBSF
    3) same results from another account, don't have another PC to test it on
    4) Europe
    5) private/personal internet account. It's possible a router is down between my server and the US (?) server?
    6) other steam PVP/online games tested with no problems.

  10. #10
    Member AnotherPersona's Avatar
    Join Date
    Apr 2013
    Location
    USA, Michigan
    Posts
    84
    So I've had quite a few people message me, having issues - not being able to log in/hanging at the main screen. Seems like it is very common today, quite odd. It took me longer than usual to log in, and my daily log-in banner doesn't pop up, but it is working ok for me, though not for many others. Seems like something that has happened in the last 24 hrs, like Yth says. One is in Portugal, another is in the USA, one in London, and another in Russia. So, it is very odd.

  11. #11
    Skald Aleonymous's Avatar
    Join Date
    Mar 2013
    Location
    Greece
    Posts
    2,444
    Hmmm... I haven't had any such problems. All these symptoms ("one day it works, the next it doesn't") lead me to believe that the problem is with the game-side of the network. It's weird because in-game traffic is really low lately, so you would expect servers to be cruising. Maybe its not a game-server issue. I am really baffled I hope the problem sorts out itself guys. Patience!

  12. #12
    Senior Member Kuba's Avatar
    Join Date
    Mar 2013
    Location
    ???
    Posts
    111
    Happened to me too. Reinstalling the game solved it.

  13. #13
    Member Yth's Avatar
    Join Date
    Mar 2013
    Location
    Vienna, Austria
    Posts
    70
    Well, it's working for me now. Yay!

  14. #14
    Hello everyone

    I got into further correspondence with John and it seems as a recently installed VPN software might have caused some issues. However, deintalling the sofrtware didn't change anything about the issue. Also, reinstalling the game didn't help. I am located in Europe, but the game worked fine up until a couple of days ago.

    Perhaps the next steam update will solve the issue.

  15. #15
    Skald Aleonymous's Avatar
    Join Date
    Mar 2013
    Location
    Greece
    Posts
    2,444
    Argail,

    So, we're sure its a network issue then. That's good for a start. Unfortunately I'm not very experienced with networking issues (port-forwarding, firewalls, allowed-applications etc), but hopefully you can "corner" the problem with a little bit of google-ing. Waiting for a Steam update can't be the optimal "move" to make

    One guess would be checking the windows-firewall (e.g. in Win7 and/or AntiVirus or other 3rd-party) for allowed-programs, and make sure that Steam/TBSF is checked.

    Another thing to try is contact Steam support. Perhaps they have a generic FAQ for such issues as yours?

  16. #16
    Hello Aleonymous

    The mighty John found the solution! The VPN program I mentioned created another internet port (kind'a thing) which I deleted and now everything runs smoothly.

    Thanks again for your help and supportive messages, I appreciate it very much.

  17. #17
    Skald Aleonymous's Avatar
    Join Date
    Mar 2013
    Location
    Greece
    Posts
    2,444
    Glad to hear it all works again, Argail! Happy pillaging

  18. #18
    Factions veteran stoicmom's Avatar
    Join Date
    May 2012
    Location
    Oak Ridge, TN
    Posts
    290
    Great news, Argail

  19. #19
    This is happening to me as well. Very strange.

    Any ideas on how to fix?

  20. #20
    Factions veteran stoicmom's Avatar
    Join Date
    May 2012
    Location
    Oak Ridge, TN
    Posts
    290
    email john@stoicstudio.com and he will help you

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •