Results 1 to 5 of 5

Thread: [BUG] Banner Saga Factions is either stuck on loading screen or gives error message

  1. #1
    Junior Member mades's Avatar
    Join Date
    Sep 2014

    [BUG] Banner Saga Factions is either stuck on loading screen or gives error message

    I searched the forum, but nothing precise was found as the "howto" fix it.

    Right now, when I load Steam first (as should be done first as pointed out in another thread), the game keeps continuously loading, without going into the game itself.

    I disabled my AV and added an exception to my firewall, still to no avail.

    Prior to this, this is what would happen (below). I am incorporating this information because this problem may come back in the near future (it may have happened because Steam was not fully launched, not sure):

    I would get the following error message when I tried starting the game. I install the game via Steam as usual, and re-installing does not change the outcome:

    Steam Error
    Steam was unable to initialize the Banner Saga

    Try each of the following options:
    1. Restart Steam
    2. Re-install The Banner Saga
    3. Re-install Steam

    I have:
    Windows 7 (Ultimate)
    NVIDIA GeForce GTX 550 Ti
    3GHZ processor
    4GB ram
    I have a firewall installed, but it would (at the very least) prompt me
    I do NOT have any VPN installed

    I only tried playing the game yesterday. It would not work, so I disabled the Steam overlay. Today, I then proceeded in re-installing the game.

    If anyone needs to see logs, I don't exactly know where they would be. I assume in the Steam directory, but there always lots of files for each game. So, I would definitely need the name of the log file if possible.

  2. #2
    Skald Aleonymous's Avatar
    Join Date
    Mar 2013
    Hello there. Sorry for the troubles you're experiencing.

    Factions has given all of us that message, from time to time, with varying frequency to each one, and with no apparent solution/fix. Me, for example, I nowadays get this like 10-20% of the times I try to launch the game, but thankfully it always works on second try. Some months ago, the frequency of that error was like 50% of the time. Then again, other people needed to try 4-5 times for the game to launch when that error occurred.

    Your system specs seem fine, and your AV & firewall shouldn't be the problem. You said you tested them, so we can rule that out. If you still wanna try sending the log files to, they can be found in C:\Users\<username>\AppData\Roaming\TheBannerSagaF actions\Local Store\logs. Zip-up the ten text-files and email them.
    Together we stand, divided we fall.

  3. #3
    Junior Member mades's Avatar
    Join Date
    Sep 2014
    Alright, will do. That specific problem does not happen anymore. Once I loaded Steam first, a newer problem arose (as indicated in the OP), the game merely never loads. Tried around 10 times, but still nothing. Hopefully the dev team can try their luck in the problem.

  4. #4
    It happens for me every time I start the game after closing my computer and leaving Steam open, the only solution is (for me) to close steam, restart steam, and open up the game. You could also try verifying your local cache.

  5. #5
    Junior Member mades's Avatar
    Join Date
    Sep 2014
    Hey Fazolt, nope nothing seems to work - even clearing the cache. Hopefully with the logs I provided they can check it out.

    @Aleonymous. So, seems I can now post without having needing my posts approved. Strangely enough, my other post I made for you was not accepted :/ I did what you suggested. That problem I do not experience (as explained in the OP). Now, all it does is get stuck at the loading screen.
    Last edited by mades; 09-29-2014 at 06:20 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts