Results 1 to 20 of 20

  Click here to go to the first staff post in this thread.   Thread: Saga Banner Faction crashes

  1. #1

    Saga Banner Faction crashes

    Yesterday I played nicely. Today there was a steam update and the program crashed. Anyone else experiencing this?

  2. #2
    Superbacker Lightbulb's Avatar
    Join Date
    May 2012
    Location
    Austria
    Posts
    5
    Yeah just tried to start it a few times after it updated, crashes every time on the loading screen...

    edit: Seems it fixed itself now.
    Last edited by Lightbulb; 02-21-2013 at 03:37 PM.

  3. #3
    Sometimes the game crashes for no apparent reason during startup. Seems to have great self-healing techniques, though

  4. #4
    I have also had the game crash a couple times on startup for me today. Always worked when I tried again though. Is there a log file or something we could attach to help troubleshoot the issue?

  5. #5
    Developer raven2134's Avatar
    Join Date
    May 2012
    Location
    Manila, Philippines
    Posts
    1,061
    Yes there's a log file:

    The game always writes log files into $HOME/tbs_logs/. You can access this or email it to us for bug reporting

    C > Users > Username >tbs_logs

    Email to community@stoicstudio.com

  6. #6
    The update on 22nd broke it for me too, hasn't recovered yet. We are not alone in this Apparently, some animation's too large now, if the logs are to be trusted

  7. #7
    There might be a memory leak, or assets are not being unloaded properly. In addition to the error message in the log (below), Task Manager shows the memory increase a lot when you enter a match, then decrease only slightly when you leave. The game launched using about 350MB (in town screen), after one game it was 700mb (in town screen) and after two was at 900mb (in town screen). I looked one time after it crashed, with not responding, and it was at 1.3GB.

    (FROM ERROR LOG, Have seen it numerous times)
    [INFO] (TBS-0) 37 2671 AnimClipDef.cacheFrames AnimClipDef{_id:"vfx_soldiers_wall", _url:"town/strand/vfx.strand.swf/vfx_soldiers_wall", _numFrames:982} is too large, giving up at frame 191/982 after MB=50

  8. #8
    And to clarify, the memory issue is not on my end, the system I use has 16GB Ram.

  9.   Click here to go to the next staff post in this thread.   #9
    I have had issues with this on my machine and deleting the local content on steam and repatching fixed the problem. If that doesn't work let me know sounds like the same problem.

    Here is more notes about crashes and fixes for them: https://stoicstudio.com/forum/showthr...-Build-1-5-106

  10. #10
    Today's update didn't fix the issue, and re-installing doesn't help either. E-mailed the log to community@ already

    The sad thing is that it worked at launch before the update came out on 22nd, I think

  11.   Click here to go to the next staff post in this thread.   #11
    bleys try saving the game on a different folder path.

  12. #12
    Just how many times trying to save to the different path is enough? It's the first thing I've done on John's advice. Retried right now to make sure nothing's changed.

  13. #13
    Junior Member Anurak's Avatar
    Join Date
    Dec 2012
    Posts
    12
    Indeed, the bug still lives. Yesterday I thought it worked after exiting the game and I assumed the problem was fixed, but maybe it was a fluke. It hasn't worked since and in its current state the game in unplayable.

    I keep telling myself that I should try it next week or the week after again, but I like it so much I keep coming back, trying to connent, only to be disappointed again. Hopefully, they will work this out soon, because the issues seem to pile up instead of reduced.

    Oh, and saving to a different folder doesn't help; I tried it with 3 different ones but I always get the same result.

  14.   This is the last staff post in this thread.   #14
    We will be inserting some diagnostics in the next build to see if we can resolve the crash.

  15. #15
    Not sure about the diagnostics, but the crash was indeed miraculously cured with the new update.

    Alas, no more first-week perks anymore

  16. #16
    Spoke too soon. The crash was back on the second launch. Sending fresh logs

  17. #17
    count me as a crasher on startup, too!

  18. #18

  19. #19
    I was also getting The Banner Saga: Factions crashing on startup, but only when launched through Steam. If I go to the install folder and manually run "The Banner Saga Factions.exe" then it works fine.

    I the noticed that if I go into the game properties within Steam and untick "Enable Steam Community In-Game" then it no longer crashes, so it's something to do with the Steam overlay I guess.

    Sadly the log file location mentioned above doesn't appear to exist on my box.

    HTH

    Muttley

  20. #20
    Skald Aleonymous's Avatar
    Join Date
    Mar 2013
    Location
    Greece
    Posts
    2,444
    Quote Originally Posted by Muttley View Post
    Sadly the log file location mentioned above doesn't appear to exist on my box.
    Hey there. Log file locations are:
    Mac OS X: ~/Library/Application Support/TheBannerSaga/Local Store/logs/
    Windows: %HOMEPATH%\AppData\Roaming\TheBannerSaga\Local Store\logs\

    This crash persists; I get it too, 50% of the time Some have fixed it by disabling the steam overlay, others by disabling the sound of the game.
    Together we stand, divided we fall.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •